Friday, November 18, 2011

Blackberry factory reset - email setting does not working

Today, I factory reset my Blackberry Torch 9800, but after reset I was not able to make email accounts works.

here are the symptoms:
1. When go email account setting, there are already existing two mail accounts there, they are the ones I set before. I am just wondering why those still stay there after factory reset.

2. I was not able to add new email accounts and not able to delete the accounts either. No options there, no menus there.

3. It prompts me to input password to validate the account. But even I input correct password, the following error message is always displayed:

"sorry, unable to continue your session. please log in again."

I searched on internet, tried to find a solutions. there are many suggestions and solutions out there for similar issue, but no one worked for me.

Here are what I have tried
- 3 times factory reset.
- remove battery
- remove SIM card
- remove "service books" under
Options - Device - Advanced - Advanced System Settings - Service book
- and many others
- It took almost 3 hours, still no result.

I was so disappointed, before I give up, I found a solution

1. Access to blackberry website from blackberry

2. Choose your country or state

3. Then scroll down the page, until you find
Communicate - Email

4. Click the Email link and follow the email setup

You will be requested to move your email accounts, just follow all the instructions and when you finished it, you are done.

No idea, but I guess the email account are cached some where on Blackberry service server. Something like and DHCP IP address. when your device address is changed, but the server is still using your old address?


loyalty said...

omg thankssssssssssssss so much it worked omg your so freaking great thanks a million god is really gonna bless you i never gave up faith i knew i would have gotten that help i have been searching online for like 2 months and finally this came up i hope I'm the first to comment on this but I'm so happy words can not explain this feeling thank you i got to tell people about this thanks a million infinity

Kevin Godfrey said...


Anonymous said...

Thank you Sir! Same problem here, but you fixed it! Searched ages, spent ages - thank you thank you!

Alvin said...

Actually I just purchased new BlackBerry smartphone and when I switch to the new one, I got another issue.

When I set up email account, the hotmail account could not be synchronized, it always saying the device has a problem to connect application service server.

I solved the problem but delete the accounts and redo the account creation.

To prevent this happening, you must remove the emails accounts from your old devices before you switch to a new one. I didn't do that, that's I was caught by the issue.

Kemron said...

I love you man! I've had blackberry for about a year now and nothing was working. I even called the support centre at O2 and they couldn't help me! You did it! Thanks so much!